2001 F250 7 3 diesel bogs down

Discussion in 'UTVUnderground's 'La Familia'' started by Cisco Kid, Oct 26, 2016.

  1. Doug8765

    Doug8765 Member

    Joined:
    Oct 24, 2014
    On mine 7.3 also it was wire harness under the valve covers got stranded twice it also helped the injectors go south too . Also hole in boost tube as well same thing 45mph


    Sent from my iPhone using Tapatalk
     
  2. Cisco Kid

    Cisco Kid Puro Corazon - UTVUnderground La Famila

    Joined:
    Apr 17, 2009
    We are replacing the wire harness and all the boost tubes ;-)
     
  3. Cisco Kid

    Cisco Kid Puro Corazon - UTVUnderground La Famila

    Joined:
    Apr 17, 2009
  4. RED RZR

    RED RZR Member

    Joined:
    Apr 13, 2011
  5. ageekwithajeep

    ageekwithajeep UTVUnderground La-Familia

    Joined:
    Oct 13, 2010
    Location:
    Spokane Wa
    I did a lot of research on this after reading that the k&n in the factory box was letting dirt through on a lot of peoples trucks, The cheapest best option I found was this
    http://www.powerstroke.org/forum/94...87-6637-diy-intake-filter-install-change.html
    I just went down to napa bought the 6637 filter, went into ace got a plastic pipe fitting that slipped into the opening, pulled the stock box out and popped it in, I am getting 2-3 Lbs more boost with it works very well.
     
  6. Cisco Kid

    Cisco Kid Puro Corazon - UTVUnderground La Famila

    Joined:
    Apr 17, 2009
    Wells Banks talk me into getting that system I posted - will see how it goes ;-)

    Banks Power Ram-Air Intake System
    • Extensively tested & validated
    • Enclosed housing keeps out hot, power-robbing engine air
    • Inhales cooler outside air for more power & MPG
    • Giant filter maximizes high-flow filtration
    • Helps engine run cooler
    • Accommodates engine movement
    • Prevents component damage
    • Extends service life and requires fewer cleanings
    • 5-year Limited Warranty (filter: Lifetime Limited Warranty)
    • Gain up to +16 hp and +32 lb-ft
    • Easy filter access for monitoring and cleaning.
    • OILED Air Filter Element
    • Emissions compliant: CARB EO D-161-102



    The problem with the open air filter is that your getting hot air from the motor and oil crap on it
     
  7. ageekwithajeep

    ageekwithajeep UTVUnderground La-Familia

    Joined:
    Oct 13, 2010
    Location:
    Spokane Wa
    Ya, I thought that too but so far so good, along with the hundred of other guys on the forums, I'm buying banks for the jeep because of the dirt and crap that is sees, its in a box like that one. Should be bueno for you. Do you have the boost tubes installed yet?
     
  8. Cisco Kid

    Cisco Kid Puro Corazon - UTVUnderground La Famila

    Joined:
    Apr 17, 2009
    We got one side all done - will be working on the other side this Turkey days ;-)
     
  9. Cisco Kid

    Cisco Kid Puro Corazon - UTVUnderground La Famila

    Joined:
    Apr 17, 2009
    So we finish installing all the parts Thursday Morning and we fire it up,

    Truck runs like caca very rough idle, like if out of time or air leak or vacuum leak dang so we take it apart again and go thru all the parts again, we started it and again caca. got piss off and work on my RZR lights.

    Later that day Thursday afternoon my nephew told me he started it and same thing, he took it for a test drive and told me it started getting better he came home and it was running better, after he had dinner he started it again and it ran like caca for 5 min and then ran better.

    he let it cool down try it again later and it ran like caca for 2 min and better. Friday he started it and no problem he took it around the block anf he told me it ran like a champ.

    On Saturday I went to turn it on and WOW it idle like a new Truck, I did not take it on a test drive, he going to take it to the shop tomorrow and connect the big computer reader to see if it has any code. Hope all come out good.

    Has anyone had or seen this type of performances that the truck fix it self ?
     
  10. ageekwithajeep

    ageekwithajeep UTVUnderground La-Familia

    Joined:
    Oct 13, 2010
    Location:
    Spokane Wa
    I had my banks chip go bad and it would not start, then when it started it would idle like caca but once running for a bit would run good. But nothing like that bogging issue when it was running.
     
  11. ageekwithajeep

    ageekwithajeep UTVUnderground La-Familia

    Joined:
    Oct 13, 2010
    Location:
    Spokane Wa
    you can test by pulling the chip off the computer on the left side of the driver footwell.
     
  12. Cisco Kid

    Cisco Kid Puro Corazon - UTVUnderground La Famila

    Joined:
    Apr 17, 2009
    K- So truck is all done - drove it home yesterday and all I can say is this thing is awesome
    I have not tow with it but let me tell you "We woke up the beast" it runs better than it ever did, got lots of power and a very fast take off ;-)
    very happy ;-)
     
  13. Rzrcsi

    Rzrcsi La Familia

    Joined:
    Jun 18, 2012
    Location:
    Central Cal.
    Glad to hear it! Hopefully she won't fall back asleep:)
     
  14. Glamisfan

    Glamisfan Active Member

    Joined:
    Oct 26, 2009
    Location:
    imperial valley
    If I let my 6.0 get low on fuel it runs like crap until I get the air out of the system.
     
  15. Cisco Kid

    Cisco Kid Puro Corazon - UTVUnderground La Famila

    Joined:
    Apr 17, 2009
    BTW - I have some free parts - pick up only - I am located right next to I-10 near Palm Springs and can meet you ;-)

    I have the AirAid Ram Intake with K and N Filter and hose connection
    I also have the OE Drive Battery Box

    Let Me know ;-)
    I can also Take them to the John Berry Ride ;-)
     

Share This Page